Why do selectable versions of PHP support some extensions in some versions but not in others?

If some PHP extensions appear in your cPanel for some versions of PHP but not others, it is because the extension developers either stopped supporting the older versions or they have not implemented support for the newer versions yet. A perfect example is PHP 4.4. Very few extensions still support it. This can also be seen in the newest experimental version.

If you need a particular extension for your purposes and it is not yet supported in your selected PHP version, take a step back one version. After the extension developer has updated support for the newer version, you can then step the version back up and turn on the extension.
  • 0 Users Found This Useful
Was this answer helpful?

Related Articles

How do I monitor who is accessing my website?

To see who is accessing your site in realtime, load up your favorite SSH client software (we use...

How do I access cPanel?

You can access your cPanel by going to http://yourdomain.com/cpanel. If your domain name has not...

What is the path to Sendmail?

/usr/sbin/sendmail   We do not use Sendmail per se, but Exim for our MTA (mail transfer agent)....

I am having a problem how do I get support?

Please log into your accout and open a support ticket. Please try to be as precise as possible...

Powered by WHMCompleteSolution